[BETA] Photo Gallery 0.1.0

Misc MOD Downloads for phpBB3 -- Any MOD that does not fit into any other category
Forum rules
Image Please feel free to download any MOD's here, support for each MOD is located it's own thread.

To post your own MOD, please first read the MOD Guidelines

How would you rate this mod?

Excellent!
43
58%
Very good
15
20%
Good
8
11%
Fair
5
7%
Poor
3
4%
 
Total votes : 74

[BETA] Photo Gallery 0.1.0

Postby Handyman » 19 Jul 2007, 10:50

Mod Author: Handyman
MOD Title: Photo Gallery
MOD Description: Adds a photo gallery for your members
MOD Version: 0.1.0
MOD Download:
photo_gallery.zip
Photo Gallery 0.1.0
(56.51 KiB) Downloaded 7239 times

Last Stable version: 0.1.0

Demo: gallery.php
Translations: https://startrekguide.bountysource.com/ ... nslations/
Bug Reports, Feature Requests and Change requests: https://startrekguide.bountysource.com/development
Upgrade: (smartors phpbb2 photo gallery to Handymans phpBB3 photo gallery) f26-scripts/t3408-photo-gallery-upgrade.html
Donate: Don?t forget donate, as I have spent a lot of time working on this mod and your support will enable me to provide future upgrades to the photo gallery, as there are many features that I still need to add

Please do not post bug reports, feature requests or change requests in this topic as they will likely get lost in the discussions.
The link above is provided for such things to help me keep organized.

Translators, please post your translation for this mod here: f101-mod-translations/t3141-photo-gallery-0-1-0-translations.html
I'll be updating the translations in the SVN daily if there are new translations.
Thanks

Personal note: (Added 7/21/2007)
I will not personally offer support for this mod during the early beta cycles because it's taking up too much of my time, not allowing me to work on updates or other mods and not helping for future releases.
If you have a support issue, please read through here and see if there is a solution for it? if not, please post a bug report, using the link provided in the first post and be as detailed as possible so I will be able to fix the issue in the next release.

I have decided to do this after answering the same questions about 5 times per day since the release and realizing that there is only 1 bug report, so it's not helping for future releases.

So I made a decision to work towards the future with a bug tracker to help keep things organized and make more stable mods for phpBB3.

Though it has been a great help to have LadySarahjane working with people on these issues? thanks very much for that sarahjane :)

I will not discourage support if anybody wants to assist other users with this mod, but I don't have a lot of available time, so my time must be spent working on the next features and any bugs reported in the tracker.


Troubleshooting (more to be added soon)
  1. If you get a blank page when you browse to gallery.php, try this f27-mods/p37543-beta-photo-gallery-0-1-0-.html#p37543
  2. The upload image doesn't show up for you. f27-miscellaneous-mods,-hacks-and-downloads/t3139-beta-photo-gallery-0-1-0-240.html#p45627
  3. When you upload an image, you get a sql error which says gallery_desc doesn't have a default value. f27-miscellaneous-mods,-hacks-and-downloads/t3139-beta-photo-gallery-0-1-0-250.html#p45646
Last edited by Handyman on 22 Nov 2007, 15:16, edited 3 times in total.
Reason: Added fix for upload button not showing.
Please contact me if you have any news to submit to SCOFF News.
SCOFFing at the candidates while you sleep.
My Mods || My Mod Queue
Image
User avatar
Handyman    
Rear Fleet Admiral
Rear Fleet Admiral
 
Posts: 7459
Joined: 08 May 2006, 04:45
Location: Where no man has gone before!
Favorite Team: Seattle Seahawks
Gender: Male


Re: [BETA] Photo Gallery 0.1.0

Postby ecwpa » 19 Jul 2007, 13:51

hello, the mod forced me to use prosilver for some reason

Code: Select all
template->_tpl_load_file(): File ./styles/prosilver/template/gallery/browse.html does not exist or is empty


i did all the changes to the other theme
sorry for my bad english :S
User avatar
ecwpa
Translator
Translator
 
Posts: 31
Joined: 21 Dec 2006, 12:35
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby rizzy » 19 Jul 2007, 14:33

The button to upload pictures does not show up when I installed this mod and I have checked over everything 3 times now and I followed everything in the directions and it is all correct in my code.
rizzy
Crewman
Crewman
 
Posts: 6
Joined: 19 Jul 2007, 14:30
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby Handyman » 19 Jul 2007, 16:46

ecwpa wrote:hello, the mod forced me to use prosilver for some reason

Code: Select all
template->_tpl_load_file(): File ./styles/prosilver/template/gallery/browse.html does not exist or is empty


i did all the changes to the other theme

Yes, I only have a prosilver template with this right now, so I had to force it.
Just upload the gallery directory into the prosilver template and you should be good to go.

There are many more updates to come, but I have prosilver ready, so I released it like that.

rizzy wrote:The button to upload pictures does not show up when I installed this mod and I have checked over everything 3 times now and I followed everything in the directions and it is all correct in my code.


Did you run gallery_db.php?
if so, go to the ACP and purge the cache.
If still nothing, go to ACP->Styles->Imagesets and click refresh on the prosilver imageset.

Make sure the image exists by browsing to forum/styles/prosilver/imageset/en/button_upload.gif
make sure you made the prosilver.txt edits.

if still nothing, let me know and we'll go from there.
Please contact me if you have any news to submit to SCOFF News.
SCOFFing at the candidates while you sleep.
My Mods || My Mod Queue
Image
User avatar
Handyman    
Rear Fleet Admiral
Rear Fleet Admiral
 
Posts: 7459
Joined: 08 May 2006, 04:45
Location: Where no man has gone before!
Favorite Team: Seattle Seahawks
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby rizzy » 19 Jul 2007, 17:26

Handyman wrote:
rizzy wrote:The button to upload pictures does not show up when I installed this mod and I have checked over everything 3 times now and I followed everything in the directions and it is all correct in my code.


Did you run gallery_db.php?
if so, go to the ACP and purge the cache.
If still nothing, go to ACP->Styles->Imagesets and click refresh on the prosilver imageset.

Make sure the image exists by browsing to forum/styles/prosilver/imageset/en/button_upload.gif
make sure you made the prosilver.txt edits.

if still nothing, let me know and we'll go from there.


Ok I went thru and double checked all of this and the upload button is still not showing up.
rizzy
Crewman
Crewman
 
Posts: 6
Joined: 19 Jul 2007, 14:30
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby Handyman » 19 Jul 2007, 17:39

rizzy wrote:
Handyman wrote:
rizzy wrote:The button to upload pictures does not show up when I installed this mod and I have checked over everything 3 times now and I followed everything in the directions and it is all correct in my code.


Did you run gallery_db.php?
if so, go to the ACP and purge the cache.
If still nothing, go to ACP->Styles->Imagesets and click refresh on the prosilver imageset.

Make sure the image exists by browsing to forum/styles/prosilver/imageset/en/button_upload.gif
make sure you made the prosilver.txt edits.

if still nothing, let me know and we'll go from there.


Ok I went thru and double checked all of this and the upload button is still not showing up.

but you were able to browse to it?
Check to make sure the button is in the database
it would be in the phpbb_styles_imagesets database? should be the last record in there.
If it's not there, go ahead and add it? purge the cache, then you should see it.
Please contact me if you have any news to submit to SCOFF News.
SCOFFing at the candidates while you sleep.
My Mods || My Mod Queue
Image
User avatar
Handyman    
Rear Fleet Admiral
Rear Fleet Admiral
 
Posts: 7459
Joined: 08 May 2006, 04:45
Location: Where no man has gone before!
Favorite Team: Seattle Seahawks
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby rizzy » 19 Jul 2007, 17:59

Handyman wrote:
rizzy wrote:
Handyman wrote:
rizzy wrote:The button to upload pictures does not show up when I installed this mod and I have checked over everything 3 times now and I followed everything in the directions and it is all correct in my code.


Did you run gallery_db.php?
if so, go to the ACP and purge the cache.
If still nothing, go to ACP->Styles->Imagesets and click refresh on the prosilver imageset.

Make sure the image exists by browsing to forum/styles/prosilver/imageset/en/button_upload.gif
make sure you made the prosilver.txt edits.

if still nothing, let me know and we'll go from there.


Ok I went thru and double checked all of this and the upload button is still not showing up.

but you were able to browse to it?
Check to make sure the button is in the database
it would be in the phpbb_styles_imagesets database? should be the last record in there.
If it's not there, go ahead and add it? purge the cache, then you should see it.


yup that is what it was, not sure why it didn't get inserted, when I ran the db file it all come back good with no errors

thanks for the help


on another note, how do i change the max upload filesize?
rizzy
Crewman
Crewman
 
Posts: 6
Joined: 19 Jul 2007, 14:30
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby HappygallyT » 19 Jul 2007, 18:30

Because I didnt see the gallery after the first install even though I refreshed and purged the cache multiple times I deleted the gallery tables directly from my database. I wanted to reinstall the mod again but when I go to gallery_db.php it keeps on saying: you already have the latest photo gallery installed.

:cray:

What should I do?
HappygallyT
Cadet I
Cadet I
 
Posts: 10
Joined: 01 Jul 2007, 17:17
Gender: Female

Re: [BETA] Photo Gallery 0.1.0

Postby HappygallyT » 19 Jul 2007, 18:36

Ok, I just dropped the ENTIRE forum and restored it again. :grin:
HappygallyT
Cadet I
Cadet I
 
Posts: 10
Joined: 01 Jul 2007, 17:17
Gender: Female

Re: [BETA] Photo Gallery 0.1.0

Postby Handyman » 19 Jul 2007, 18:38

HappygallyT wrote:Ok, I just dropped the ENTIRE forum and restored it again. :grin:

:shock: does it work now?
Please contact me if you have any news to submit to SCOFF News.
SCOFFing at the candidates while you sleep.
My Mods || My Mod Queue
Image
User avatar
Handyman    
Rear Fleet Admiral
Rear Fleet Admiral
 
Posts: 7459
Joined: 08 May 2006, 04:45
Location: Where no man has gone before!
Favorite Team: Seattle Seahawks
Gender: Male

Next

Return to Miscellaneous MODs, Hacks and Downloads

Who is online

Users browsing this forum: No registered users and 5 guests