[BETA] Photo Gallery 0.1.0

Misc MOD Downloads for phpBB3 -- Any MOD that does not fit into any other category
Forum rules
Image Please feel free to download any MOD's here, support for each MOD is located it's own thread.

To post your own MOD, please first read the MOD Guidelines

How would you rate this mod?

Excellent!
43
58%
Very good
15
20%
Good
8
11%
Fair
5
7%
Poor
3
4%
 
Total votes : 74

Re: [BETA] Photo Gallery 0.1.0

Postby T50Webmaster » 13 Sep 2008, 15:22

yng_mastr wrote:well.. just that i installed the mod, had too many buggy problems. Found a similar but better mod. Installed it without any problems. So i edited my post, with the listed problems, and mentioned that i removed the mod.

of course it's going to be buggy, it's in beta, it isn't meant to be used on a live forum. only test boards..

also, listing the bugs and errors helps to improve the mod and get rid of the issues. that's why it's released for people to test it, I mean you can't expect the mod author to be able to find every possible bug or error, I mean some bugs are related to certain hosts and stuff.
pssst...I heard that!!!
Free and paid webhosting
Busy with life, just IM me, or PM me at 110mb.com/forum

Webmaster of a Northeast Wisconsin Boy Scout Troop Website, http://bsat50.info
T50Webmaster    
MOD Author
MOD Author
 
Posts: 629
Joined: 26 Mar 2007, 11:09
Location: Right where my Butt IS!!!
Favorite Team: phpbb
Gender: Male
phpBB Knowledge: 3


Re: [BETA] Photo Gallery 0.1.0

Postby guignol » 30 Sep 2008, 02:13

hello,

sorry in advance for my english ...

my problem is when i install the gallery_db.php
i have this message

Code: Select all
General Error
SQL ERROR [ mysql4 ]

Field 'gallery_desc' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_gallery (gallery_name) VALUES ('Member Galleries')

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: gallery_db.php
LINE: 273
CALL: dbal_mysql->sql_query()



do you know where is the problems ? and it's possible to have the sql code for create and insert manually ?

thank you in advance
guignol
Crewman
Crewman
 
Posts: 1
Joined: 30 Sep 2008, 01:40
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby Peppers » 05 Oct 2008, 10:07

I'm getting this problem too. Can someone tell me how to fix it, thanks.
Peppers
Crewman
Crewman
 
Posts: 3
Joined: 27 Sep 2008, 12:28
Gender: Male
phpBB Knowledge: 1

Re: [BETA] Photo Gallery 0.1.0

Postby Handyman » 05 Oct 2008, 14:46

everything you need to make this work is already in this topic? the search does wonders :)

I'm not too lazy to use the search, so here's the link: viewtopic.php?f=27&t=3139&p=58474&hilit=photo+gallery+default+value#p58474
Please contact me if you have any news to submit to SCOFF News.
SCOFFing at the candidates while you sleep.
My Mods || My Mod Queue
Image
User avatar
Handyman    
Rear Fleet Admiral
Rear Fleet Admiral
 
Posts: 7459
Joined: 08 May 2006, 04:45
Location: Where no man has gone before!
Favorite Team: Seattle Seahawks
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby patty68 » 29 Jan 2009, 13:22

Hello

how can i make that i see the modules of Photo Gallery in my acp?? It gives a instruction to do this?? It exist in german?

Thx

Patrick
patty68    
Crewman
Crewman
 
Posts: 1
Joined: 04 Jan 2009, 01:48
Gender: Male

Re: [BETA] Photo Gallery 0.1.0

Postby Chadneu » 14 Mar 2009, 18:40

Alright so I'm having a pretty random problem with mine.

After the last PHPBB update, my photo gallery broke. It comes back with this error.

Fatal error: Call to undefined function mb_internal_encoding() in /home/chadneuc/public_html/forums/includes/gallery/gallery_main.php on line 60

After removing line 60 I get

Fatal error: Call to undefined function mb_strlen() in /home/chadneuc/public_html/forums/includes/gallery/gallery_main.php on line 175

After that I'm clueless on what to do. Do i need to change my php settings?


Nevermind, this post, viewtopic.php?f=27&t=3139&p=45455&hilit=gallery_main.php#p45455, fixed it.
Chadneu
Crewman
Crewman
 
Posts: 1
Joined: 14 Mar 2009, 18:38
Gender: Male
phpBB Knowledge: 6

Re: [BETA] Photo Gallery 0.1.0

Postby RichardH » 16 Mar 2009, 15:37

phpBB3.0.4
AeroBlue
php 5.2.4
MySQL 5.0.67

Well, I uploaded the files and made the modifications.
Then I launched /gallery_db.php
Here's the return:
Code: Select all
General Error
SQL ERROR [ mysqli ]

Field 'gallery_desc' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_gallery (gallery_name) VALUES ('Member Galleries')

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: gallery_db.php
LINE: 273
CALL: dbal_mysqli->sql_query()


includes/db/mysqli.php LINE: 161-163
Code: Select all
            if (($this->query_result = @mysqli_query($this->db_connect_id, $query)) === false)
            {
               $this->sql_error($query);


gallery_db.php LINE: 272 & 273
Code: Select all
$sql = "INSERT INTO {$table_prefix}gallery " . $db->sql_build_array('INSERT', $sql_ary);
$db->sql_query($sql);


Is this trying to use MySQL Lite?
Any ideas?
RichardH    
Crewman
Crewman
 
Posts: 1
Joined: 16 Mar 2009, 15:20
Gender: Male
phpBB Knowledge: 3

Re: [BETA] Photo Gallery 0.1.0

Postby Aurelye » 08 Apr 2009, 02:55

I've installed your mod, but i've got a couple of problems.

First i copied the files. Then i did the edits. Then i ran the gallery_db.php. I got the error Field 'gallery_desc' doesn't have a default value [1364]. So after a search of this post i found the fix, edited the files and ran it again. This time it worked, and it said i'd installed the gallery correctly. I flushed the cache, added the module to the acp and flushed the cache again.

Sure enough the Link pops up and i can enter the gallery. Now comes the couple of problems. First, i have 3 of every link. Eg view gallery, view photo etc etc. I've visited acp and yes there's 3 of each. I tried deleting them but i can't it says they have children. I can disable some of them to give the view i want on the board, but i'd like to know how to get rid of them.

Second problem is the biggie. When i go to upload a picture, i still get the Field 'gallery_desc' doesn't have a default value [1364] error. And note, i DID edit the file and reran gallery_db.php, and i did search this forum for as much help as i could get, thats before someone just tells me to go and search.

Thanks in advance.
Aurelye    
Crewman
Crewman
 
Posts: 1
Joined: 08 Apr 2009, 02:48
Gender: Male
phpBB Knowledge: 3

Re: [BETA] Photo Gallery 0.1.0

Postby ionmic » 17 Jan 2010, 09:01

hi,

this mod is still on beta? because i want to use and i have some problem about install.
ionmic
Crewman
Crewman
 
Posts: 1
Joined: 17 Jan 2010, 08:55
Gender: Male
phpBB Knowledge: 2

Re: [BETA] Photo Gallery 0.1.0

Postby Anthies » 20 Feb 2010, 02:35

Does this mod work with 3.0.6?
Anthies    
Cadet I
Cadet I
 
Posts: 17
Joined: 15 Oct 2009, 08:58
Location: Finland
Favorite Team: Real Madrid FC
Gender: Male
phpBB Knowledge: 8

PreviousNext

Return to Miscellaneous MODs, Hacks and Downloads

Who is online

Users browsing this forum: EasouSpider and 2 guests