Default Avatar

Styles, Theme, Cosmetic and Appearance related tips, tricks, tweaks, and Graphics

Moderator: STG Styles Team

Forum rules
NOTE: Post full styles only in the Styles Forum

Re: Default Avatar

Postby Sappy » 18 Jun 2008, 16:58

I have bug:
avatar.jpg


My code:
Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <!-- IF postrow.U_POST_AUTHOR --><br /><a href="{postrow.U_POST_AUTHOR}">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><!-- ELSE --><br /><img src="{T_THEME_PATH}/images/no_avatar.gif" width="150" height="150" alt="" /><br />
Sappy
Cadet I
Cadet I
 
Posts: 10
Joined: 05 May 2008, 17:38
Gender: Male
phpBB Knowledge: 3




phpBB Academy at StarTrekGuide
Support STG
Using PayPal Donate

Re: Default Avatar

Postby Stoker » 18 Jun 2008, 23:30

Sappy wrote:I have bug:
avatar.jpg


My code:
Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <!-- IF postrow.U_POST_AUTHOR --><br /><a href="{postrow.U_POST_AUTHOR}">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><!-- ELSE --><br /><img src="{T_THEME_PATH}/images/no_avatar.gif" width="150" height="150" alt="" /><br />



Try this instead:
Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <!-- IF postrow.U_POST_AUTHOR --><a href="{postrow.U_POST_AUTHOR}">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><!-- ELSE --><img src="{T_THEME_PATH}/images/no_avatar.gif" width="90" height="90" alt="" />
                             <!-- ENDIF --><br />
Last edited by Stoker on 24 Jun 2008, 23:53, edited 1 time in total.
Stoker
Stoker    
Borg Drone
Borg Drone
 
Posts: 401
Joined: 24 Nov 2007, 11:05
Location: Denmark
Favorite Team: Highslide JS
Gender: Male
phpBB Knowledge: 4

Re: Default Avatar

Postby Sappy » 19 Jun 2008, 03:14

Tnx, perfekt! :thumbsup:
Sappy
Cadet I
Cadet I
 
Posts: 10
Joined: 05 May 2008, 17:38
Gender: Male
phpBB Knowledge: 3

Re: Default Avatar

Postby sunka » 16 Jul 2008, 07:36

Long time ago (3 months ago) If I remember correct, I install some MOD (or just a trick code) if you click on users avatar, it shows them user profile (it is same when you click on username on forum...it leads straight to user profile),...And that is working OK, but because of that, no longer is working default avatar (it is also tricky code...little code change) for users (it is default avatar for all users untill they choose another one from gallery or upload their own).

This is modified code with both trickies (prosilver/template/viewtopic_body.html)

Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <a href="{postrow.U_POST_AUTHOR}#viewprofile" onclick="return hs.htmlExpand(this, { objectType: 'ajax', width: 700, slideshowGroup: '{postrow.U_PROFILE}'} )">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><br /><!-- ELSE --><img src="{T_THEME_PATH}/images/no_avatar.gif" width="90" height="90" alt="" /><br />
            <!-- ENDIF -->


And this is without line for click on avatar to see profile

Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <!-- IF postrow.U_POST_AUTHOR --><a href="{postrow.U_POST_AUTHOR}">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><br /><!-- ELSE --><img src="{T_THEME_PATH}/images/no_avatar.gif" width="90" height="90" alt="" /><br />
            <!-- ENDIF -->


And this is virgin unmodified (vanilla) file

Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <!-- IF postrow.U_POST_AUTHOR --><a href="{postrow.U_POST_AUTHOR}">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><br />
            <!-- ENDIF -->


Could someone help me to sove this and both modification work??
sunka    
Crewman
Crewman
 
Posts: 9
Joined: 07 Apr 2008, 09:39
Gender: Male
phpBB Knowledge: 2

Re: Default Avatar

Postby Stoker » 16 Jul 2008, 14:40

Hi sunka

Try this:
Code: Select all
<!-- IF postrow.POSTER_AVATAR -->
               <a href="{postrow.U_POST_AUTHOR}#viewprofile" onclick="return hs.htmlExpand(this, { objectType: 'ajax', width: 700, slideshowGroup: '{postrow.U_PROFILE}'} )">{postrow.POSTER_AVATAR}</a><!-- ELSE -->{postrow.POSTER_AVATAR}<!-- ENDIF --><br /><!-- ELSE --><a href="{postrow.U_POST_AUTHOR}#viewprofile" onclick="return hs.htmlExpand(this, { objectType: 'ajax', width: 700, slideshowGroup: '{postrow.U_PROFILE}'} )"><img src="{T_THEME_PATH}/images/no_avatar.gif" width="90" height="90" alt="" /></a><br />
            <!-- ENDIF -->


I haven't testet this so please get back to me and tell if it works.
Stoker
Stoker    
Borg Drone
Borg Drone
 
Posts: 401
Joined: 24 Nov 2007, 11:05
Location: Denmark
Favorite Team: Highslide JS
Gender: Male
phpBB Knowledge: 4

Re: Default Avatar

Postby sunka » 16 Jul 2008, 16:08

Hi Stoker...how is it in Denmark? :)
No, it's not working...still no default Avatar for users with yet not choose some avatar with free will.

Hope that you find solution :beg:

Btw, If I remembered correct, Higslide is your MOD...and if it is, let me give you another problem to find solution :grin:
Somehow grey colour not working anymore when I click on picture attached in posts (grey colour for background effect, I think you know what I mean)....and one more mistake (not yours), with new Firefox v3.0.0, pictures (when click on them) open extremly fast (there is not effect of "step by step" picture resized) - Sorry for that kind of words to describe my problems...I am not so good in english language yet, but I am learning :good:
sunka    
Crewman
Crewman
 
Posts: 9
Joined: 07 Apr 2008, 09:39
Gender: Male
phpBB Knowledge: 2

Re: Default Avatar

Postby Stoker » 16 Jul 2008, 23:39

Hi Sunka

Denmark is nice, but the sun isn't shining :cray:
I think You forgot to refresh the template after You uploaded the changed file?

About the Highslide thing, You should update the script: http://www.stokershoppen.dk/highslidede ... .php?id=75
Stoker
Stoker    
Borg Drone
Borg Drone
 
Posts: 401
Joined: 24 Nov 2007, 11:05
Location: Denmark
Favorite Team: Highslide JS
Gender: Male
phpBB Knowledge: 4

Re: Default Avatar

Postby sunka » 17 Jul 2008, 01:08

No, it is not working
Look on picture, user Hoppla with no Avatar at all

Image

Of course, I purged cache and refresh complete Style components (template, imageset, theme

EDIT: For highslide, I just update highslide full java script (refresh all styles and purged cache), but there is still missing grey effect
sunka    
Crewman
Crewman
 
Posts: 9
Joined: 07 Apr 2008, 09:39
Gender: Male
phpBB Knowledge: 2

Re: Default Avatar

Postby Stoker » 17 Jul 2008, 01:26

Du You have the no_avatar.gif in Your prosilver/theme/images folder?

About the lightbox effect:
Make sure that You have done this: http://www.phpbb.com/community/viewtopi ... 5#p4836865
Stoker
Stoker    
Borg Drone
Borg Drone
 
Posts: 401
Joined: 24 Nov 2007, 11:05
Location: Denmark
Favorite Team: Highslide JS
Gender: Male
phpBB Knowledge: 4

Re: Default Avatar

Postby sunka » 17 Jul 2008, 01:45

Yes, I have no_avatar.gif there
First modification added was for default avatar, and that was working...after that I modified for Avatar linking to profile, and that is working, but first one not...

Yep, highslide working very well...I forgot to edit
Code: Select all
dimmingOpacity: 0.85, // Lightbox style dimming background
in higslide java script when I update month ago...now it is working OK.
Last edited by sunka on 17 Jul 2008, 02:03, edited 1 time in total.
sunka    
Crewman
Crewman
 
Posts: 9
Joined: 07 Apr 2008, 09:39
Gender: Male
phpBB Knowledge: 2

PreviousNext

Return to Styles Tweaks, Tips and Graphics

Who is online

Users browsing this forum: No registered users and 1 guest